SoFunction
Updated on 2024-11-14

Example of python determining if a number is divisible by another integer

Determining whether a number is divisible by another integer is a fairly simple problem, usually a modulo operation can be done, lazy Xiaomeng still do not want to do it yourself, so find you to help him write code, you help him.

input format

The input consists of two space-separated integers M and N (1≤M,N≤500).

output format

The output consists of one line, YES if M is divisible by N, NO otherwise (the result is case sensitive).

Sample Input

21 7

Sample Output

YES

str = input()
nums = ()
if int(nums[0]) % int(nums[1]) == 0:
 print("YES")
else:
 print("NO")

String Separation followed by Type Conversion and then Simple Modulo Arithmetic

The above example of this python to determine whether a number is divisible by another integer is all that I have shared with you.